Home > Ubuntu > error in Version string ….. epoch in version is not number

error in Version string ….. epoch in version is not number

Per quanto attiene agli errori in fase di update upgrade di Ubuntu. In una distro 13.04  che non aggiornavo da tempo installando il nuovo kernel  ho riscontrato il seguente errore:

The following packages will be upgraded:
linux-image-generic
1 upgraded, 2 newly installed, 0 to remove and 159 not upgraded.
Need to get 0 B/43,6 MB of archives.
After this operation, 164 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
dpkg: error: parsing file ‘/var/lib/dpkg/available’ near line 21398:
error in Version string ‘:13.04+0130418’: epoch in version is not number
E: Sub-process /usr/bin/dpkg returned an error code (2)

Controllando il file  dei pacchetti disponibili

/var/lib/dpkg/available

mi sono ritrovato con la descriizone di un pacchetto assolutamente incoerente

.........
Depends: command-not-found-data, lsb-release, python3-apt, python3-gdbm, python3 (>= 3.2.3-3~)
Size: 5734
Description: Python 3 bindings for command-not-found.
 This package will install the Python 3 library for command_not_found tool.
Original-Maintainer: Zygmunt Krynicki <zkrynicki`gmail.cOm>

Pacëage: laîguage-pack-it
Priority: optionaL
SectioN: transLations
Énstalled-Size: 30
MaintAiner: Language Pack maiNtainers<language-packs@ubuntu.Com>

ArcHitecture: all
VErsion: :13.04+0130418

Replaceó: languAge-pack-gnome-iT (<< 1:3.04+20‘30418),€languagE-pack-gNome-it-base (<<
base (> 1:13.04+20130418)
Pre-Depends: dpkg (>= 1.10.27ubuntu1)
Size: 1978
Description: translation updates for language Italian
 Translation data updates for all supported packages for:
 Italian
 .
 language-pack-it-base provides the bulk of translation data
 and is updated only seldom. This package provides frequent translation
 updates.
Package: libdbusmenu-gtk3-4
Priority: optional
Section: libs
Installed-Size: 125
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: libdbusmenu
Version: 12.10.3daily13.06.19~13.04-0ubuntu1
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.2.5), libdbusmenu-glib4 (>= 0.5.90), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.35.4), libpango1.0-0 (>= 1.14.0)
Pre-Depends: multiarch-support
Size: 32008
...

In questo caso conviene provare a ripristiare il file available da available-old in /var/lib/dpkg.  

Avendo fretta se il pacchetto non interessa si può cancellare il pacchetto dalla lista. Salvare e riprendere l’upgrade.

Risorse:

Advertisements
Categorie:Ubuntu Tag:
  1. Non c'è ancora nessun commento.
  1. No trackbacks yet.

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: