Home > Ubuntu > Ubuntu 12 Update Manager si ferma come sbloccare

Ubuntu 12 Update Manager si ferma come sbloccare

Sboccare Update Manager che si ferma con ubuntu 12.04 e ubuntu 12.10 su

flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.243.orig.tar.gz

seguito da un messaggio del tipo

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

utilizzando però il comando suggerito sudo dpkg –configure -a   si riferma su flash plugin

maurizio@Mau-US-12:~$ sudo dpkg --configure -a
Setting up update-notifier-common (0.119ubuntu8.6) ...
flashplugin-installer: downloading http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.243.orig.tar.gz

^CTraceback (most recent call last):
  File "/usr/lib/update-notifier/package-data-downloader", line 296, in 
    process_download_requests()
  File "/usr/lib/update-notifier/package-data-downloader", line 234, in process_download_requests
    dest_file = urllib.urlretrieve(files[i])[0]
  File "/usr/lib/python2.7/urllib.py", line 93, in urlretrieve
    return _urlopener.retrieve(url, filename, reporthook, data)
  File "/usr/lib/python2.7/urllib.py", line 267, in retrieve
    block = fp.read(bs)
  File "/usr/lib/python2.7/socket.py", line 380, in read
    data = self._sock.recv(left)
KeyboardInterrupt
dpkg: error processing update-notifier-common (--configure):
 subprocess installed post-installation script was interrupted
dpkg: dependency problems prevent configuration of flashplugin-installer:
 flashplugin-installer depends on update-notifier-common (>= 0.119ubuntu2); however:
  Package update-notifier-common is not configured yet.
dpkg: error processing flashplugin-installer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on update-notifier-common (= 0.119ubuntu8.6); however:
  Package update-notifier-common is not configured yet.
dpkg: error processing update-notifier (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 update-notifier-common
 flashplugin-installer
 update-notifier

controlliamo la situazione dei pacchetti flash con

maurizio@Mau-US-12:~$ sudo dpkg -l flash*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name             Version          Description
+++-================-================-================================================
un  flashplayer-mozi            (no description available)
un  flashplugin                 (no description available)
un  flashplugin-down            (no description available)
iU  flashplugin-inst 11.2.202.243ubun Adobe Flash Player plugin installer
un  flashplugin-nonf            (no description available)

A questo punto non resta che rimuovere il pacchetto flashplugin-installer.

Per interrompere la fase di update si possono utilizzare a seconda della situazione CTRL-C o kill.

Quindi bisogna controllare che non siano pendenti processi che accedono agli archivi apt.  Questi potrebbero bloccare il funzionamento dei programmi di installazione e rimozioni dei pacchetti.

I processi pendenti possono essere cercati con

ps afx | grep [d]pkg

e

ps fax | grep "apt-get"
maurizio@Lub12120:~/sopcast-player$ ps afx | grep "dpkg"
 2471 pts/22   S+     0:00  |   \_ grep --color=auto dpkg
 2186 pts/26   SNs+   0:00      \_ /usr/bin/dpkg --status-fd 81 --unpack --auto-deconfigure /var/cache/apt/archives/flashplugin-installer_11.2.202.251ubuntu0.12.10.1_amd64.deb
 2200 pts/26   SN+    0:00          \_ /bin/sh /var/lib/dpkg/info/update-notifier-common.postinst triggered /usr/share/package-data-downloads

Se esistono processi pendenti come in questo vanno terminati con kill.
Ad esempio in questo caso ..

sudo kill 2186 2200

Per rimuovere flashplugin-installer

sudo apt-get remove flashplugin-installer

Per rimuovere il pacchetto è possibile utilizzare anche synaptic.

Comandi utili:

  sudo dpkg --configure -a

per sistemare dipendenze

sudo apt-get install -f
Advertisements
  1. Non c'è ancora nessun commento.
  1. No trackbacks yet.

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: